Slow webpage response
Incident Report for CSGOStats
Resolved
This incident has been resolved.
Posted Feb 19, 2022 - 10:27 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 18, 2022 - 18:17 UTC
Investigating
We're investigating an issue causing the website to be very slow to respond.
Posted Feb 17, 2022 - 19:17 UTC
This incident affected: Web (csgostats.gg).